Nov 16 2009

Errores comunes del comando apt-get

apt-get es un comando que usamos por consola para hacer algunas operaciones. Necesita permisos de root o superusuario y no podemos usarlo a la vez que el gestor de paquetes synaptics o el gestor de actualizaciones.

Los errores más comunes son:
Sin permiso de superusuario o root
Por ejemplo, para actualizar la lista de paquetes
apt-get update
E: No se pudo abrir el fichero de bloqueo ‘/var/lib/apt/lists/lock’ – open (13: Permiso denegado)
E: No se pudo bloquear el directorio de listas

Este error quiere decir que se nos ha olvidado abrirlo como super usuario. Simplemente escribiremos
sudo apt-get update
metemos nuestra contraseña y listo.

Tenemos el gestor de paquetes synaptics abierto, o el gestor de actualizaciones

sudo apt-get update
[…]
E: No se pudo bloquear /var/lib/dpkg/lock – open (11: Recurso temporalmente no disponible)
E: Imposible bloquear el directorio de administración (/var/lib/dpkg/), ¿está otro proceso usándolo?

Cerramos synaptics o el gestor de actualizaciones y volvemos a escribirlo. Solucionado.

A 7 usuari@s les gusta este tutorial - Me gusta
Be Sociable, Share!

Etiquetas: , , , , , , , ,


4 comentarios en “Errores comunes del comando apt-get”

  1. lety dijo:

    lo hice pero me sale E: Encountered a section with no Package: header
    E: Problem with MergeList /var/lib/apt/lists/do.archive.ubuntu.com_ubuntu_dists_jaunty-updates_restricted_binary-i386_Packages
    E: No se pudieron analizar o abrir las listas de paquetes o el archivo de estado.

    ayuda porfaaaaa!!!

  2. Sara dijo:

    genial! es muy útil esta información para mí como noob de ubuntu gracias!

  3. Ilan dijo:

    gracias

  4. Carlos dijo:

    Funciona :) Gracias!

Dejar un comentario